$re = '/\\\\caption(?:of)?+\b(?:\[[^][]*\])?+\s*+(?!(\{(?:[^}{]++|(?-1))*+\}))/';
$str = ' \\begin{figure}
\\includegraphics{pic.pdf}
\\caption[]{My caption \\\\
Source: XYZ
\\label{fig:pic_1}
\\end{figure}
\\begin{figure}[H]
\\includegraphics{pic.pdf}
\\captionof[]{My caption \\\\ xyz \\\\ abc
\\label{fig:pic_1} }
\\end{figure}
\\begin{figure}[H]
\\includegraphics{pic.pdf}
\\caption[]{My caption {with extra brackets}
Source: XYZ}
\\label{fig:pic_1}
\\end{figure}
\\begin{figure}[H]
\\includegraphics{pic.pdf}
\\caption[]{My caption}
\\end{figure}
Some text\\\\ %% This \\\\ should not be changed, it\'s not within a caption
More text
\\begin{figure}[H]
\\includegraphics{pic.pdf}
\\caption[]{My caption \\\\ Source: XYZ}
\\label{fig:pic_1}
\\end{figure}';
$subst = "\\par";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;