import Foundation
let pattern = #"\\caption(?:of)?+\b(?:\[[^][]*\])?+\s*+(?!(\{(?:[^}{]++|(?-1))*+\}))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
\begin{figure}
\includegraphics{pic.pdf}
\caption[]{My caption \\
Source: XYZ
\label{fig:pic_1}
\end{figure}
\begin{figure}[H]
\includegraphics{pic.pdf}
\captionof[]{My caption \\ xyz \\ abc
\label{fig:pic_1} }
\end{figure}
\begin{figure}[H]
\includegraphics{pic.pdf}
\caption[]{My caption {with extra brackets}
Source: XYZ}
\label{fig:pic_1}
\end{figure}
\begin{figure}[H]
\includegraphics{pic.pdf}
\caption[]{My caption}
\end{figure}
Some text\\ %% This \\ should not be changed, it's not within a caption
More text
\begin{figure}[H]
\includegraphics{pic.pdf}
\caption[]{My caption \\ Source: XYZ}
\label{fig:pic_1}
\end{figure}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\par"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)