$re = '/"(r\'([a-z0-9]+(\.[a-z0-9]+)*@[a-z]+(\.[a-z]+)+)\')"/m';
$str = '"r\'a1.b2@c.d\'"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);