re = /"(r'([a-z0-9]+(\.[a-z0-9]+)*@[a-z]+(\.[a-z]+)+)')"/m
str = '"r\'a1.b2@c.d\'"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end