import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^arn:(aws|aws-cn|aws-us-gov):([a-zA-Z0-9-]+):([a-zA-Z0-9-]*):(\\d{12}|):([^:/]+)([:/].*)?$";
final String string = "AWS\n"
+ "arn:aws:s3:::my-s3-bucket\n"
+ "arn:aws:iam::123456789012:user/JohnDoe\n"
+ "arn:aws:dynamodb:us-east-1:123456789012:table/UserTable\n"
+ "arn:aws:lambda:us-west-2:123456789012:function:ProcessData\n"
+ "arn:aws:ec2:us-east-1:123456789012:instance/i-0abcd1234efgh5678\n\n"
+ "GOOGLE CLOUD\n"
+ "projects/my-project-id/buckets/my-storage-bucket\n"
+ "projects/my-project-id/zones/us-central1-a/instances/instance-1\n"
+ "projects/my-project-id/topics/my-pubsub-topic\n"
+ "projects/my-project-id/datasets/my_bigquery_dataset\n"
+ "projects/my-project-id/instances/my-cloud-sql-instance\n\n"
+ "AZURE\n"
+ "/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.KeyVault/vaults/MyKeyVault\n"
+ "/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.Storage/storageAccounts/mystorageacct\n"
+ "/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.Compute/virtualMachines/MyVM\n"
+ "/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.Web/sites/MyAppService\n"
+ "/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.DocumentDB/databaseAccounts/MyCosmosDB";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}