# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^arn:(aws|aws-cn|aws-us-gov):([a-zA-Z0-9-]+):([a-zA-Z0-9-]*):(\d{12}|):([^:/]+)([:/].*)?$"
test_str = ("AWS\n"
"arn:aws:s3:::my-s3-bucket\n"
"arn:aws:iam::123456789012:user/JohnDoe\n"
"arn:aws:dynamodb:us-east-1:123456789012:table/UserTable\n"
"arn:aws:lambda:us-west-2:123456789012:function:ProcessData\n"
"arn:aws:ec2:us-east-1:123456789012:instance/i-0abcd1234efgh5678\n\n"
"GOOGLE CLOUD\n"
"projects/my-project-id/buckets/my-storage-bucket\n"
"projects/my-project-id/zones/us-central1-a/instances/instance-1\n"
"projects/my-project-id/topics/my-pubsub-topic\n"
"projects/my-project-id/datasets/my_bigquery_dataset\n"
"projects/my-project-id/instances/my-cloud-sql-instance\n\n"
"AZURE\n"
"/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.KeyVault/vaults/MyKeyVault\n"
"/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.Storage/storageAccounts/mystorageacct\n"
"/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.Compute/virtualMachines/MyVM\n"
"/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.Web/sites/MyAppService\n"
"/subscriptions/12345678-1234-1234-1234-123456789012/resourceGroups/MyResourceGroup/providers/Microsoft.DocumentDB/databaseAccounts/MyCosmosDB")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.