const regex = /^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[!?-_.:,;+*~#'´`\\={}()\/&%$§"])[A-Za-z0-9!?-_.:,;+*~#'´`\\={}()\/&%$§"]{8,32}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[!?-_.:,;+*~#\'´`\\\\={}()\\\/&%$§"])[A-Za-z0-9!?-_.:,;+*~#\'´`\\\\={}()\\\/&%$§"]{8,32}$', '')
const str = `Passwort1234!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}