$re = '/^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[!?-_.:,;+*~#\'´`\\\\={}()\/&%$§"])[A-Za-z0-9!?-_.:,;+*~#\'´`\\\\={}()\/&%$§"]{8,32}$/';
$str = 'Passwort1234!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);