package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#.*(*SKIP)(*F)|bbb|ccc`)
var str = `aaa bbb ccc ddd eee
#aaa bbb ccc ddd eee
#aaa bbb ccc ddd eee
aaa bbb ccc ddd eee`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}