re = /#.*(*SKIP)(*F)|bbb|ccc/
str = 'aaa bbb ccc ddd eee
#aaa bbb ccc ddd eee
#aaa bbb ccc ddd eee
aaa bbb ccc ddd eee'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end