const regex = /^((\d+[wdhm]\ +?)+|\d+)\ *(.*)$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\d+[wdhm]\\ +?)+|\\d+)\\ *(.*)$', 'gim')
const str = `3w 4d 8h 12m Test string
15m Test string
123 Test
50 Test
123
1h Test
2h Test
3d 4h Test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}