#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:Jr|Master|Mr|Ms|Mrs|Dr|Capt|Col|Sgt|Sr|Prof|Rep|Mt|Mount|St|Etc|Eg)\.\s+|["'“(\[]?)(?:\b(?:(?!(?:\S{1,})[.?!]+["']?\s+["']?[A-Z]).)*)(?:(?:(?:Jr|Master|Mr|Ms|Mrs|Dr|Capt|Col|Sgt|Sr|Prof|Rep|Mt|Mount|St|Etc|Eg)\.\s+(?:(?!\w{2,}[.?!]['"]?\s+["']?[A-Z]).)*)?)*(?:(?![.?!]["']?\s+["']?\w).)*(?:[.?!)\]]+["'”]?|[^\r\n]+$)"
Local $sString = "PROBLEM: "This is a problem. You hear me?"" & @CRLF & _
"" & @CRLF & _
"Possible problem/exception sentence (Does not properly split due to "Mr."): On Feb. 20 Mr. X said "Beyond the fourth wall, there shall be 'light'"?!... Or something. Second sentence. Third." & @CRLF & _
"" & @CRLF & _
"Possible problem/exception ("Really?" should not split before Capital names?: "Really?" Mr. baker asked, as he proceeded to ponder." & @CRLF & _
"" & @CRLF & _
"This is a new line without ending punctuation" & @CRLF & _
"Ending punctuation problem solved, almost" & @CRLF & _
"Yep it solved" & @CRLF & _
"" & @CRLF & _
"'Dr. T.G. Walker alarmed the whole 20.50 train when Mr. T.G. Walker got up shouting at 10 o'clock.' "The exchange rate was at 500.72." After the crowd dissipated the police also went home. 'Mr. Sherlock Holmes and Dr. John Watson and Mrs. Williams together with T.G. Hooker and Capt. Marshall, of course, were better than the F.B.I. at crime fighting. Feb. 20 Mr. Barack Obama vowed as a candidate before Rep. TestNameAbbreviation that he would put the U.S. on a path to addressing climate change A.S.A.P!!!" & @CRLF & _
"" & @CRLF & _
"Is that really the case, Anthony? Why yes, yes it is. Is that really the case? Really, is it, so? Well then!" & @CRLF & _
"Please do so, A.S.A.P! Help us please!" & @CRLF & _
"This is from I.T? Yes, it is. No, it is not." & @CRLF & _
"" & @CRLF & _
"x for eg., y etc., and i.e, z." & @CRLF & _
"x for eg. y etc. and i.e z." & @CRLF & _
"On Saturday, Sgt. Timothy said..." & @CRLF & _
"Sgt. Timothy said ..." & @CRLF & _
"It was I! For they are dead." & @CRLF & _
"Trailing punctuation test!!!!!! Test?!. Test?!. Test!? Test?! Test...test...." & @CRLF & _
"Harry, you're a 'wizard'. Yes, really."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")