use strict;
my $str = 'PROBLEM: "This is a problem. You hear me?"
Possible problem/exception sentence (Does not properly split due to "Mr."): On Feb. 20 Mr. X said "Beyond the fourth wall, there shall be \'light\'"?!... Or something. Second sentence. Third.
Possible problem/exception ("Really?" should not split before Capital names?: "Really?" Mr. baker asked, as he proceeded to ponder.
This is a new line without ending punctuation
Ending punctuation problem solved, almost
Yep it solved
\'Dr. T.G. Walker alarmed the whole 20.50 train when Mr. T.G. Walker got up shouting at 10 o\'clock.\' "The exchange rate was at 500.72." After the crowd dissipated the police also went home. \'Mr. Sherlock Holmes and Dr. John Watson and Mrs. Williams together with T.G. Hooker and Capt. Marshall, of course, were better than the F.B.I. at crime fighting. Feb. 20 Mr. Barack Obama vowed as a candidate before Rep. TestNameAbbreviation that he would put the U.S. on a path to addressing climate change A.S.A.P!!!
Is that really the case, Anthony? Why yes, yes it is. Is that really the case? Really, is it, so? Well then!
Please do so, A.S.A.P! Help us please!
This is from I.T? Yes, it is. No, it is not.
x for eg., y etc., and i.e, z.
x for eg. y etc. and i.e z.
On Saturday, Sgt. Timothy said...
Sgt. Timothy said ...
It was I! For they are dead.
Trailing punctuation test!!!!!! Test?!. Test?!. Test!? Test?! Test...test....
Harry, you\'re a \'wizard\'. Yes, really.';
my $regex = qr/(?:(?:Jr|Master|Mr|Ms|Mrs|Dr|Capt|Col|Sgt|Sr|Prof|Rep|Mt|Mount|St|Etc|Eg)\.\s+|["'“(\[]?)(?:\b(?:(?!(?:\S{1,})[.?!]+["']?\s+["']?[A-Z]).)*)(?:(?:(?:Jr|Master|Mr|Ms|Mrs|Dr|Capt|Col|Sgt|Sr|Prof|Rep|Mt|Mount|St|Etc|Eg)\.\s+(?:(?!\w{2,}[.?!]['"]?\s+["']?[A-Z]).)*)?)*(?:(?![.?!]["']?\s+["']?\w).)*(?:[.?!)\]]+["'”]?|[^\r\n]+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}