import re
regex = re.compile(r"(\d+)-(\d+)\s+(.*)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("3-01 Wait for It.mp4\n"
"3-02 We're Not from Here.mp4\n"
"3-03 Third Wheel.mp4\n"
"3-04 Little Boys.mp4\n"
"3-05 How I Met Everyone Else.mp4\n"
"3-06 I'm Not That Guy.mp4\n"
"3-07 Dowisetrepla.mp4\n"
"3-08 Spoiler Alert.mp4\n"
"3-09 Slapsgiving.mp4\n"
"3-10 The Yips.mp4\n"
"3-11 The Platinum Rule.mp4\n"
"3-12 No Tomorrow.mp4\n"
"3-13 Ten Sessions.mp4\n"
"3-14 The Bracket.mp4\n"
"3-15 The Chain of Screaming.mp4\n"
"3-16 Sandcastles in the Sand.mp4\n"
"3-17 The Goat.mp4\n"
"3-18 Rebound Bro.mp4")
subst = "How I Met Your Mother S$1E$2 $3"
result = regex.sub(subst, test_str)
if result:
print(result)