using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"##(?P<tag>\w+)=<(?:(?P<key>\w+)=(?P<value>[^,<>]*),?)*>";
string input = @"##TAG=<key=val,key2=val2>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}