package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)##(?P<tag>\w+)=<(?:(?P<key>\w+)=(?P<value>[^,<>]*),?)*>`)
var str = `##TAG=<key=val,key2=val2>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}