$re = '/^.+?\/objet-test\/\d+$/m';
$str = 'set-publicitaire-securite-enfant/objet-test/35687
http://www.test.com/set-publicitaire-securite-enfant/objet-test/35687';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);