re = /^.+?\/objet-test\/\d+$/m
str = 'set-publicitaire-securite-enfant/objet-test/35687
http://www.test.com/set-publicitaire-securite-enfant/objet-test/35687'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end