import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ab.*[zy].*s";
final String string = "abrazos\n"
+ "abyes\n"
+ "abys\n"
+ "abysm\n"
+ "abysmal\n"
+ "abysmally\n"
+ "abysms\n"
+ "free\n"
+ "friday\n"
+ "smelly\n\n"
+ "Write a regular expression to find all words which have the first two characters of \"ab\", and after that at some point EITHER a \"z\" or a \"y\", and then after that at some point an \"s\". The \"s\" does not have to be at the end of the word. \n\n"
+ "So the following words are all examples of words which you should be able to find (although there are many more words which match which are not listed here):";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}