import re
regex = re.compile(r"^ab.*[zy].*s")
test_str = ("abrazos\n"
"abyes\n"
"abys\n"
"abysm\n"
"abysmal\n"
"abysmally\n"
"abysms\n"
"free\n"
"friday\n"
"smelly\n\n"
"Write a regular expression to find all words which have the first two characters of \"ab\", and after that at some point EITHER a \"z\" or a \"y\", and then after that at some point an \"s\". The \"s\" does not have to be at the end of the word. \n\n"
"So the following words are all examples of words which you should be able to find (although there are many more words which match which are not listed here):")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")