re = /(?<=\w\.)\s*([a-z]+)/
str = 'A proper sentence. And another one.
A proper sentence. and a bad one.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end