using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[img]((?:https?|ftps?)://[^\s?&=\#\""<]*?\.(?:jpe?g|gif|png))\[/img]";
string input = @"[img]http://www.test.com/abc.jpg[/img]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}