package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[img]((?:https?|ftps?)://[^\s?&=\#\"<]*?\.(?:jpe?g|gif|png))\[/img]`)
var str = `[img]http://www.test.com/abc.jpg[/img]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}