$re = '/"\w+":"(\w+)"/';
$str = '"something":"thestring"
"something":[{"thestring":{"key":18,"anotherkey":"astring"}}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);