re = /"\w+":"(\w+)"/
str = '"something":"thestring"
"something":[{"thestring":{"key":18,"anotherkey":"astring"}}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end