const regex = /(\d)(,)(\d{3})(?=(?=.*?:).*?~.*?;0*\1\3_(.)(.{3}))|(\d)(,)(\d{3})(?=.*?:)|(\d)(:)|(#),/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(,)(\\d{3})(?=(?=.*?:).*?~.*?;0*\\1\\3_(.)(.{3}))|(\\d)(,)(\\d{3})(?=.*?:)|(\\d)(:)|(#),', 'g')
const str = `#,0001,0110,0010:~;0101_1000;0110_1001;0111_1010;1000_1011;1001_1100;1010_1101;1011_1110;1100_1111,~0_00001_00012_00103_00114_01005_01016_01107_01118_10009_1001,`;
const subst = `$2$7$4$6$5$8$10$9$11`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);