$re = '/(\d)(,)(\d{3})(?=(?=.*?:).*?~.*?;0*\1\3_(.)(.{3}))|(\d)(,)(\d{3})(?=.*?:)|(\d)(:)|(#),/';
$str = '#,0001,0110,0010:~;0101_1000;0110_1001;0111_1010;1000_1011;1001_1100;1010_1101;1011_1110;1100_1111,~0_00001_00012_00103_00114_01005_01016_01107_01118_10009_1001,';
$subst = "$2$7$4$6$5$8$10$9$11";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;