# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.)\n(\S)"
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.\n"
"Dictum sit amet justo donec enim diam vulputate.\n"
"Nunc faucibus a pellentesque sit amet.\n\n"
"Quis enim lobortis scelerisque fermentum dui faucibus in.\n"
"Leo duis ut diam quam nulla porttitor massa id neque.\n"
"Vitae tortor condimentum lacinia quis vel eros.")
subst = "\\1 \\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.