#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=OF 8 )(\S+)"
Local $sString = "07/26/2021 09:41:00 => [Debug] Execution started for file: For_ReadingText_PDF" & @CRLF & _
"07/26/2021 09:41:01 => [Info] DataScraping_From_Drawing_PDF execution started" & @CRLF & _
"07/26/2021 09:41:02 => [Debug] 4 3 2 1" & @CRLF & _
"BILL OF MATERIALS REV REL NO REVISION DWN CKD APVD DATE" & @CRLF & _
"ITEM QTY DESCRIPTION PART NUMBER REV 0 X RELEASED TO PROTOTYPE PX375 X X 12OCT18" & @CRLF & _
"1 1 BRACKET; AIR CLEANER A061P694-1 0" & @CRLF & _
"2 2 GUSSET; AIR CLEANER A061P694-2 0" & @CRLF & _
"3 1 GUSSET; AIR CLEANER A061P694-3 0" & @CRLF & _
"4 2 GUSSET; AIR CLEANER A061P694-4 0 NOTES:" & @CRLF & _
"5 1 GUSSET; AIR CLEANER A061P694-5 0 1. STEEL STAMP COUNTRY OF ORIGIN," & @CRLF & _
"PART NUMBER, AND REVISION LEVEL PER" & @CRLF & _
"D 6 1 GUSSET; AIR CLEANER A061P694-6 0 CPP STD. 17,012. D" & @CRLF & _
"2. DEBUR & BREAK ALL SHARP CORNERS." & @CRLF & _
"3. FINISH TO BE LAVA BLACK PER CPP STD. 18,008." & @CRLF & _
"4. OPTIONAL PAINT: RAL 9005." & @CRLF & _
"A. MATERIAL: CPP STD 12,002" & @CRLF & _
"5. WELD STANDARD:" & @CRLF & _
"A. ALL WELD SYMBOL SHALL CONFORM TO AWS A2.4." & @CRLF & _
"B. WELD DISCONTINUTIES SHALL NOT EXCEED ISO 5817" & @CRLF & _
"BOTH SIDES QUALITY LEVEL B." & @CRLF & _
"1.3 C. WELD FILLER MATERIAL MUST CONFORM TO AWS A5.18 ER70S-6." & @CRLF & _
"DETAIL B" & @CRLF & _
"SCALE .375" & @CRLF & _
"" & @CRLF & _
"C C" & @CRLF & _
"2 2 PLACES 5" & @CRLF & _
"2X 30.2 86.6 233.7" & @CRLF & _
"[1.19] [3.41] [9.20] 4" & @CRLF & _
"" & @CRLF & _
"6" & @CRLF & _
"" & @CRLF & _
"B B" & @CRLF & _
"4 CORNERS" & @CRLF & _
"1 -2 2" & @CRLF & _
"49.5 1-2 2X 362" & @CRLF & _
"[1.95] [14.25]" & @CRLF & _
"82.6 1" & @CRLF & _
"2X 108 [3.25]" & @CRLF & _
"[4.25] 1.5 1-2" & @CRLF & _
"42.7 203.5 1.6 61.2 1-2" & @CRLF & _
"[1.68] [8.01] [2.41] 133.4" & @CRLF & _
"57.2 [5.25]" & @CRLF & _
"A [2.25] 2 PLACES 1-3 3 A" & @CRLF & _
"2 PLACES 3 SEE DETAIL B DIMENSIONS ARE IN: MILLIMETERS CMI DATA CLASSIFICATION" & @CRLF & _
"[ ] ARE IN: INCHES DO NOT SCALE PRINT Cummins Confidential Cummins Inc." & @CRLF & _
"DRAWING TOLERANCES APPLY TO PRIMARY" & @CRLF & _
"DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .150 DWN B.SARKAR PX375 ITEM NAME" & @CRLF & _
"" & @CRLF & _
"X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER" & @CRLF & _
"X.X: # .1 IN OR 0.7 mm" & @CRLF & _
"X.XX: # .030 IN OR 0.25 mm APVD X" & @CRLF & _
"X.XXX: # .010 IN OR 0.075 mm REAR MOUNT" & @CRLF & _
"ANGULAR TOLERANCE: # 1$ DATE 12OCT18" & @CRLF & _
"CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG" & @CRLF & _
"THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV" & @CRLF & _
"IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING," & @CRLF & _
"USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 1 OF 8 A061P694 0" & @CRLF & _
"4 3 2 14 3 2 1" & @CRLF & _
"NOTES:" & @CRLF & _
"1. ALL BENDS TO BE 90$ UNLESS OTHERWISE STATED." & @CRLF & _
"[4.00] [15.82]" & @CRLF & _
"2. BEND RADII TO EQUAL MATERIAL THICKNESS." & @CRLF & _
"101.6 401.8 3. MATERIAL: CPP STD 11,101" & @CRLF & _
"A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR" & @CRLF & _
"4. OPTIONAL MATERIAL THICKNESS : 0.250 INCH." & @CRLF & _
"D 4X n11.4 D" & @CRLF & _
"[.45]" & @CRLF & _
"203.2 503.4" & @CRLF & _
"0 [8.00] [19.82]" & @CRLF & _
"[0] 36.6" & @CRLF & _
"2X 50.8 [1.44]" & @CRLF & _
"[2.00] R6.4 TYP" & @CRLF & _
"2X 100.8 [.25]" & @CRLF & _
"[3.97]" & @CRLF & _
"112.8" & @CRLF & _
"[4.44] 0 [.55] [15.26]" & @CRLF & _
"[0] [6.53] [13.44]" & @CRLF & _
"2X 165.9 341.4 387.6" & @CRLF & _
"2X 14" & @CRLF & _
"(203 )" & @CRLF & _
"C VIEW A [7.99] C" & @CRLF & _
"A" & @CRLF & _
"(600.7 )" & @CRLF & _
"[23.65]" & @CRLF & _
"" & @CRLF & _
"210$ 426.2" & @CRLF & _
"[16.78]" & @CRLF & _
"2X 370.2" & @CRLF & _
"[14.58]" & @CRLF & _
"304.8 4X n10.7" & @CRLF & _
"B [12.00] [.42] B" & @CRLF & _
"2X n6.4" & @CRLF & _
"[.25]" & @CRLF & _
"2X 167" & @CRLF & _
"127 [6.58]" & @CRLF & _
"[5.00]" & @CRLF & _
"76.2" & @CRLF & _
"[3.00]" & @CRLF & _
"0 0" & @CRLF & _
"[0] 2X n13 [0]" & @CRLF & _
"0 [.91] [11.06] [14.93] [.51] 69.1" & @CRLF & _
"[0] [2.72]" & @CRLF & _
"2X 23.1 2X 280.9 2X 379.2" & @CRLF & _
"82.6" & @CRLF & _
"A [3.25] A" & @CRLF & _
"[5.69] [5.03] [2.53] [1.94] [0]" & @CRLF & _
"DIMENSIONS ARE IN: MILLIMETERS CMI DATA CLASSIFICATION" & @CRLF & _
"[ ] ARE IN: INCHES DO NOT SCALE PRINT Cummins Confidential Cummins Inc." & @CRLF & _
"6.4 THICK 144.5 127.8 64.3 49.3 0 DRAWING TOLERANCES APPLY TO PRIMARY" & @CRLF & _
"[.250] DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME" & @CRLF & _
"" & @CRLF & _
"X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER" & @CRLF & _
"X.X: # .1 IN OR 0.7 mm" & @CRLF & _
"X.XX: # .030 IN OR 0.25 mm APVD X" & @CRLF & _
"X.XXX: # .010 IN OR 0.075 mm REAR MOUNT" & @CRLF & _
"ANGULAR TOLERANCE: # 1$ DATE 12OCT18" & @CRLF & _
"CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG" & @CRLF & _
"THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV" & @CRLF & _
"IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING," & @CRLF & _
"USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 2 OF 8 A061P694 0" & @CRLF & _
"4 3 2 14 3 2 1" & @CRLF & _
"NOTES:" & @CRLF & _
"1. MATERIAL: CPP STD 11,101" & @CRLF & _
"A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR" & @CRLF & _
"2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH" & @CRLF & _
"" & @CRLF & _
"D D" & @CRLF & _
"" & @CRLF & _
"C C" & @CRLF & _
"" & @CRLF & _
"[14.00] [.75]" & @CRLF & _
"355.6 19.1" & @CRLF & _
"6.4 THICK" & @CRLF & _
"[.250]" & @CRLF & _
"0" & @CRLF & _
"12.7 [0]" & @CRLF & _
"[.50] 19.1" & @CRLF & _
"B R6.4 TYP [.75] B" & @CRLF & _
"[.25]" & @CRLF & _
"82.6" & @CRLF & _
"[3.25]" & @CRLF & _
"[2.50] 0" & @CRLF & _
"63.5 [0]" & @CRLF & _
"" & @CRLF & _
"A A" & @CRLF & _
"DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc." & @CRLF & _
"[ ] ARE IN: INCHES Cummins Confidential" & @CRLF & _
"DRAWING TOLERANCES APPLY TO PRIMARY" & @CRLF & _
"DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME" & @CRLF & _
"" & @CRLF & _
"X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER" & @CRLF & _
"X.X: # .1 IN OR 0.7 mm" & @CRLF & _
"X.XX: # .030 IN OR 0.25 mm APVD X" & @CRLF & _
"X.XXX: # .010 IN OR 0.075 mm REAR MOUNT" & @CRLF & _
"ANGULAR TOLERANCE: # 1$ DATE 12OCT18" & @CRLF & _
"CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG" & @CRLF & _
"THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV" & @CRLF & _
"IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING," & @CRLF & _
"USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 4 OF 8 A061P694 0" & @CRLF & _
"4 3 2 14 3 2 1" & @CRLF & _
"NOTES:" & @CRLF & _
"1. MATERIAL: CPP STD 11,101" & @CRLF & _
"A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR" & @CRLF & _
"2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH." & @CRLF & _
"" & @CRLF & _
"D D" & @CRLF & _
"" & @CRLF & _
"[.50] [0]" & @CRLF & _
"C 12.7 0 6.4 THICK C" & @CRLF & _
"[.250]" & @CRLF & _
"127" & @CRLF & _
"[5.00]" & @CRLF & _
"" & @CRLF & _
"R6.4 TYP" & @CRLF & _
"[.25]" & @CRLF & _
"" & @CRLF & _
"63.5" & @CRLF & _
"[2.50]" & @CRLF & _
"" & @CRLF & _
"B B" & @CRLF & _
"" & @CRLF & _
"19.1" & @CRLF & _
"[.75]" & @CRLF & _
"0" & @CRLF & _
"[0]" & @CRLF & _
"49.5 [.75]" & @CRLF & _
"[1.95] 19.1" & @CRLF & _
"" & @CRLF & _
"A A" & @CRLF & _
"DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc." & @CRLF & _
"[ ] ARE IN: INCHES Cummins Confidential" & @CRLF & _
"DRAWING TOLERANCES APPLY TO PRIMARY" & @CRLF & _
"DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME" & @CRLF & _
"" & @CRLF & _
"X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER" & @CRLF & _
"X.X: # .1 IN OR 0.7 mm" & @CRLF & _
"X.XX: # .030 IN OR 0.25 mm APVD X" & @CRLF & _
"X.XXX: # .010 IN OR 0.075 mm REAR MOUNT" & @CRLF & _
"ANGULAR TOLERANCE: # 1$ DATE 12OCT18" & @CRLF & _
"CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG" & @CRLF & _
"THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV" & @CRLF & _
"IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING," & @CRLF & _
"USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 5 OF 8 A061P694 0" & @CRLF & _
"4 3 2 14 3 2 1" & @CRLF & _
"NOTES:" & @CRLF & _
"1. MATERIAL: CPP STD 11,101" & @CRLF & _
"A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR" & @CRLF & _
"2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH" & @CRLF & _
"" & @CRLF & _
"D D" & @CRLF & _
"" & @CRLF & _
"C C" & @CRLF & _
"" & @CRLF & _
"R6.4" & @CRLF & _
"[.25]" & @CRLF & _
"" & @CRLF & _
"B 25.4 B" & @CRLF & _
"[1.00]" & @CRLF & _
"" & @CRLF & _
"108 6.4 THICK" & @CRLF & _
"[4.25] [.250]" & @CRLF & _
"" & @CRLF & _
"A A" & @CRLF & _
"DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc." & @CRLF & _
"[ ] ARE IN: INCHES Cummins Confidential" & @CRLF & _
"DRAWING TOLERANCES APPLY TO PRIMARY" & @CRLF & _
"DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME" & @CRLF & _
"" & @CRLF & _
"X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER" & @CRLF & _
"X.X: # .1 IN OR 0.7 mm" & @CRLF & _
"X.XX: # .030 IN OR 0.25 mm APVD X" & @CRLF & _
"X.XXX: # .010 IN OR 0.075 mm REAR MOUNT" & @CRLF & _
"ANGULAR TOLERANCE: # 1$ DATE 12OCT18" & @CRLF & _
"CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG" & @CRLF & _
"THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV" & @CRLF & _
"IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING," & @CRLF & _
"USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 6 OF 8 A061P694 0" & @CRLF & _
"4 3 2 14 3 2 1" & @CRLF & _
"NOTES:" & @CRLF & _
"1. MATERIAL: CPP STD 11,101" & @CRLF & _
"A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR" & @CRLF & _
"2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH" & @CRLF & _
"" & @CRLF & _
"D D" & @CRLF & _
"" & @CRLF & _
"C C" & @CRLF & _
"" & @CRLF & _
"B B" & @CRLF & _
"2X R6.4" & @CRLF & _
"[.25]" & @CRLF & _
"" & @CRLF & _
"25.4" & @CRLF & _
"[1.00]" & @CRLF & _
"" & @CRLF & _
"387.6" & @CRLF & _
"[15.26]" & @CRLF & _
"6.4 THICK" & @CRLF & _
"[.250]" & @CRLF & _
"" & @CRLF & _
"A A" & @CRLF & _
"DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc." & @CRLF & _
"[ ] ARE IN: INCHES Cummins Confidential" & @CRLF & _
"DRAWING TOLERANCES APPLY TO PRIMARY" & @CRLF & _
"DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME" & @CRLF & _
"" & @CRLF & _
"X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER" & @CRLF & _
"X.X: # .1 IN OR 0.7 mm" & @CRLF & _
"X.XX: # .030 IN OR 0.25 mm APVD X" & @CRLF & _
"X.XXX: # .010 IN OR 0.075 mm REAR MOUNT" & @CRLF & _
"ANGULAR TOLERANCE: # 1$ DATE 12OCT18" & @CRLF & _
"CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG" & @CRLF & _
"THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV" & @CRLF & _
"IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING," & @CRLF & _
"USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 7 OF 8 A061P694 0" & @CRLF & _
"4 3 2 14 3 2 1" & @CRLF & _
"NOTES:" & @CRLF & _
"1. MATERIAL: CPP STD 11,101" & @CRLF & _
"A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR" & @CRLF & _
"2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH." & @CRLF & _
"" & @CRLF & _
"D D" & @CRLF & _
"" & @CRLF & _
"C C" & @CRLF & _
"2X R6.4 12.7" & @CRLF & _
"[.25] [.50]" & @CRLF & _
"" & @CRLF & _
"49.5" & @CRLF & _
"[1.95]" & @CRLF & _
"" & @CRLF & _
"19.1" & @CRLF & _
"B [.75] B" & @CRLF & _
"" & @CRLF & _
"42.5 .38 X 45$ CHAMFER 6.4 THICK" & @CRLF & _
"[1.68] [.250]" & @CRLF & _
"" & @CRLF & _
"A A" & @CRLF & _
"DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc." & @CRLF & _
"[ ] ARE IN: INCHES Cummins Confidential" & @CRLF & _
"DRAWING TOLERANCES APPLY TO PRIMARY" & @CRLF & _
"DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .188 DWN B.SARKAR PX375 ITEM NAME" & @CRLF & _
"" & @CRLF & _
"X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER" & @CRLF & _
"X.X: # .1 IN OR 0.7 mm" & @CRLF & _
"X.XX: # .030 IN OR 0.25 mm APVD X" & @CRLF & _
"X.XXX: # .010 IN OR 0.075 mm REAR MOUNT" & @CRLF & _
"ANGULAR TOLERANCE: # 1$ DATE 12OCT18" & @CRLF & _
"CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG" & @CRLF & _
"THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV" & @CRLF & _
"IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING," & @CRLF & _
"USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 8 OF 8 A061P694 0" & @CRLF & _
"4 3 2 1" & @CRLF & _
"07/26/2021 09:41:02 => [Info] DataScraping_From_Drawing_PDF execution ended in: 00:00:01" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")