re = /(?<=OF 8 )(\S+)/m
str = '07/26/2021 09:41:00 => [Debug] Execution started for file: For_ReadingText_PDF
07/26/2021 09:41:01 => [Info] DataScraping_From_Drawing_PDF execution started
07/26/2021 09:41:02 => [Debug] 4 3 2 1
BILL OF MATERIALS REV REL NO REVISION DWN CKD APVD DATE
ITEM QTY DESCRIPTION PART NUMBER REV 0 X RELEASED TO PROTOTYPE PX375 X X 12OCT18
1 1 BRACKET; AIR CLEANER A061P694-1 0
2 2 GUSSET; AIR CLEANER A061P694-2 0
3 1 GUSSET; AIR CLEANER A061P694-3 0
4 2 GUSSET; AIR CLEANER A061P694-4 0 NOTES:
5 1 GUSSET; AIR CLEANER A061P694-5 0 1. STEEL STAMP COUNTRY OF ORIGIN,
PART NUMBER, AND REVISION LEVEL PER
D 6 1 GUSSET; AIR CLEANER A061P694-6 0 CPP STD. 17,012. D
2. DEBUR & BREAK ALL SHARP CORNERS.
3. FINISH TO BE LAVA BLACK PER CPP STD. 18,008.
4. OPTIONAL PAINT: RAL 9005.
A. MATERIAL: CPP STD 12,002
5. WELD STANDARD:
A. ALL WELD SYMBOL SHALL CONFORM TO AWS A2.4.
B. WELD DISCONTINUTIES SHALL NOT EXCEED ISO 5817
BOTH SIDES QUALITY LEVEL B.
1.3 C. WELD FILLER MATERIAL MUST CONFORM TO AWS A5.18 ER70S-6.
DETAIL B
SCALE .375
C C
2 2 PLACES 5
2X 30.2 86.6 233.7
[1.19] [3.41] [9.20] 4
6
B B
4 CORNERS
1 -2 2
49.5 1-2 2X 362
[1.95] [14.25]
82.6 1
2X 108 [3.25]
[4.25] 1.5 1-2
42.7 203.5 1.6 61.2 1-2
[1.68] [8.01] [2.41] 133.4
57.2 [5.25]
A [2.25] 2 PLACES 1-3 3 A
2 PLACES 3 SEE DETAIL B DIMENSIONS ARE IN: MILLIMETERS CMI DATA CLASSIFICATION
[ ] ARE IN: INCHES DO NOT SCALE PRINT Cummins Confidential Cummins Inc.
DRAWING TOLERANCES APPLY TO PRIMARY
DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .150 DWN B.SARKAR PX375 ITEM NAME
X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER
X.X: # .1 IN OR 0.7 mm
X.XX: # .030 IN OR 0.25 mm APVD X
X.XXX: # .010 IN OR 0.075 mm REAR MOUNT
ANGULAR TOLERANCE: # 1$ DATE 12OCT18
CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG
THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV
IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING,
USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 1 OF 8 A061P694 0
4 3 2 14 3 2 1
NOTES:
1. ALL BENDS TO BE 90$ UNLESS OTHERWISE STATED.
[4.00] [15.82]
2. BEND RADII TO EQUAL MATERIAL THICKNESS.
101.6 401.8 3. MATERIAL: CPP STD 11,101
A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR
4. OPTIONAL MATERIAL THICKNESS : 0.250 INCH.
D 4X n11.4 D
[.45]
203.2 503.4
0 [8.00] [19.82]
[0] 36.6
2X 50.8 [1.44]
[2.00] R6.4 TYP
2X 100.8 [.25]
[3.97]
112.8
[4.44] 0 [.55] [15.26]
[0] [6.53] [13.44]
2X 165.9 341.4 387.6
2X 14
(203 )
C VIEW A [7.99] C
A
(600.7 )
[23.65]
210$ 426.2
[16.78]
2X 370.2
[14.58]
304.8 4X n10.7
B [12.00] [.42] B
2X n6.4
[.25]
2X 167
127 [6.58]
[5.00]
76.2
[3.00]
0 0
[0] 2X n13 [0]
0 [.91] [11.06] [14.93] [.51] 69.1
[0] [2.72]
2X 23.1 2X 280.9 2X 379.2
82.6
A [3.25] A
[5.69] [5.03] [2.53] [1.94] [0]
DIMENSIONS ARE IN: MILLIMETERS CMI DATA CLASSIFICATION
[ ] ARE IN: INCHES DO NOT SCALE PRINT Cummins Confidential Cummins Inc.
6.4 THICK 144.5 127.8 64.3 49.3 0 DRAWING TOLERANCES APPLY TO PRIMARY
[.250] DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME
X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER
X.X: # .1 IN OR 0.7 mm
X.XX: # .030 IN OR 0.25 mm APVD X
X.XXX: # .010 IN OR 0.075 mm REAR MOUNT
ANGULAR TOLERANCE: # 1$ DATE 12OCT18
CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG
THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV
IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING,
USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 2 OF 8 A061P694 0
4 3 2 14 3 2 1
NOTES:
1. MATERIAL: CPP STD 11,101
A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR
2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH
D D
C C
[14.00] [.75]
355.6 19.1
6.4 THICK
[.250]
0
12.7 [0]
[.50] 19.1
B R6.4 TYP [.75] B
[.25]
82.6
[3.25]
[2.50] 0
63.5 [0]
A A
DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc.
[ ] ARE IN: INCHES Cummins Confidential
DRAWING TOLERANCES APPLY TO PRIMARY
DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME
X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER
X.X: # .1 IN OR 0.7 mm
X.XX: # .030 IN OR 0.25 mm APVD X
X.XXX: # .010 IN OR 0.075 mm REAR MOUNT
ANGULAR TOLERANCE: # 1$ DATE 12OCT18
CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG
THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV
IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING,
USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 4 OF 8 A061P694 0
4 3 2 14 3 2 1
NOTES:
1. MATERIAL: CPP STD 11,101
A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR
2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH.
D D
[.50] [0]
C 12.7 0 6.4 THICK C
[.250]
127
[5.00]
R6.4 TYP
[.25]
63.5
[2.50]
B B
19.1
[.75]
0
[0]
49.5 [.75]
[1.95] 19.1
A A
DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc.
[ ] ARE IN: INCHES Cummins Confidential
DRAWING TOLERANCES APPLY TO PRIMARY
DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME
X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER
X.X: # .1 IN OR 0.7 mm
X.XX: # .030 IN OR 0.25 mm APVD X
X.XXX: # .010 IN OR 0.075 mm REAR MOUNT
ANGULAR TOLERANCE: # 1$ DATE 12OCT18
CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG
THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV
IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING,
USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 5 OF 8 A061P694 0
4 3 2 14 3 2 1
NOTES:
1. MATERIAL: CPP STD 11,101
A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR
2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH
D D
C C
R6.4
[.25]
B 25.4 B
[1.00]
108 6.4 THICK
[4.25] [.250]
A A
DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc.
[ ] ARE IN: INCHES Cummins Confidential
DRAWING TOLERANCES APPLY TO PRIMARY
DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME
X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER
X.X: # .1 IN OR 0.7 mm
X.XX: # .030 IN OR 0.25 mm APVD X
X.XXX: # .010 IN OR 0.075 mm REAR MOUNT
ANGULAR TOLERANCE: # 1$ DATE 12OCT18
CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG
THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV
IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING,
USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 6 OF 8 A061P694 0
4 3 2 14 3 2 1
NOTES:
1. MATERIAL: CPP STD 11,101
A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR
2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH
D D
C C
B B
2X R6.4
[.25]
25.4
[1.00]
387.6
[15.26]
6.4 THICK
[.250]
A A
DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc.
[ ] ARE IN: INCHES Cummins Confidential
DRAWING TOLERANCES APPLY TO PRIMARY
DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .250 DWN B.SARKAR PX375 ITEM NAME
X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER
X.X: # .1 IN OR 0.7 mm
X.XX: # .030 IN OR 0.25 mm APVD X
X.XXX: # .010 IN OR 0.075 mm REAR MOUNT
ANGULAR TOLERANCE: # 1$ DATE 12OCT18
CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG
THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV
IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING,
USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 7 OF 8 A061P694 0
4 3 2 14 3 2 1
NOTES:
1. MATERIAL: CPP STD 11,101
A. OPTIONAL MATERIAL: EN10025-2 Grade S355JR
2. OPTIONAL MATERIAL THICKNESS : 0.250 INCH.
D D
C C
2X R6.4 12.7
[.25] [.50]
49.5
[1.95]
19.1
B [.75] B
42.5 .38 X 45$ CHAMFER 6.4 THICK
[1.68] [.250]
A A
DIMENSIONS ARE IN: MILLIMETERS DO NOT SCALE PRINT CMI DATA CLASSIFICATION Cummins Inc.
[ ] ARE IN: INCHES Cummins Confidential
DRAWING TOLERANCES APPLY TO PRIMARY
DIMENSIONS UNLESS OTHERWISE SPECIFIED SCALE .188 DWN B.SARKAR PX375 ITEM NAME
X: # 1 IN OR 4 mm CKD X R BRACKET, AIR CLEANER
X.X: # .1 IN OR 0.7 mm
X.XX: # .030 IN OR 0.25 mm APVD X
X.XXX: # .010 IN OR 0.075 mm REAR MOUNT
ANGULAR TOLERANCE: # 1$ DATE 12OCT18
CONFIDENTIAL AND PROPRIETARY AND SHALL NOT BE DISCLOSED TO OTHERS MUST CONFORM DWG
THIS DOCUMENT (AND THE INFORMATION SHOWN THEREON) IS FOR INTERPRETATION OF SIZE CAD SHEET ITEM NUMBER REV
IN HARD COPY OR ELECTRONIC FORM, REPRODUCED BY ANY MEANS, OR DIMENSIONING AND TOLERANCING,
USED FOR ANY PURPOSE WITHOUT WRITTEN CONSENT OF CUMMINS INC. SEE ASME Y14.5-2009 TO CES 10903 C 8 OF 8 A061P694 0
4 3 2 1
07/26/2021 09:41:02 => [Info] DataScraping_From_Drawing_PDF execution ended in: 00:00:01
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end