const regex = new RegExp('\\[\\(\\'(\\d+)\\'(,) (\\d+)\\)\\]', 'gm')
const str = `[('15000042', 19)]`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);