re = /\[\('(\d+)'(,) (\d+)\)\]/m
str = '[(\'15000042\', 19)]'
subst = '\\1\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result