package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\d\s*){1,3})`)
var str = `1 23 4`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}