$re = '/((?:\d\s*){1,3})/';
$str = '1 23 4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);