const regex = /\{(.*?)\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{(.*?)\\}', 'g')
const str = `title={key players in the earth system},
author={Devid, Jhon A and SWAT, David J and Franks, Peter J},
journal={Current opinion in plant biology},`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}