$re = '/\{(.*?)\}/';
$str = 'title={key players in the earth system},
author={Devid, Jhon A and SWAT, David J and Franks, Peter J},
journal={Current opinion in plant biology},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);