$re = '/^Name[:]?\s([A-Z][-\'a-zA-Z]+)\s([A-Z][-\'a-zA-Z]+)$/m';
$str = 'Name Rakesh Rao
Name: Ramachandra Deshpande';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);