re = /^Name[:]?\s([A-Z][-'a-zA-Z]+)\s([A-Z][-'a-zA-Z]+)$/m
str = 'Name Rakesh Rao
Name: Ramachandra Deshpande'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end