package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\[.+\]\]`)
var str = `Good morning [[user_name]]. Lorem ipsum dolor sit amet, consectetur adipiscing elit [[other_user_name]] sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}