const regex = /\[\[.+\]\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[.+\\]\\]', 'g')
const str = `Good morning [[user_name]]. Lorem ipsum dolor sit amet, consectetur adipiscing elit [[other_user_name]] sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}