#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(^ *)CREATE\s+TABLE\s+[^()]*\(([^()]*\([^()]*\))*[^()]*\)"
Local $sString = "CREATE TABLE [dbo].[m_category_link](" & @CRLF & _
" [category_link_id] [int] NOT NULL," & @CRLF & _
" [category_id] [int] NULL," & @CRLF & _
" [parent_id] [int] NULL," & @CRLF & _
" [child_id] [int] NULL" & @CRLF & _
") ON [PRIMARY]" & @CRLF & _
"GO" & @CRLF & _
"" & @CRLF & _
"CREATE TABLE [dbo].[m_daihyou_syouhin_wk](" & @CRLF & _
" [daihyou_cd] [varchar](30) NOT NULL," & @CRLF & _
" [syuuyaku_cd] [varchar](30) NULL," & @CRLF & _
" [daihyou_mei] as ([daihyou_cd]+ [syuuyaku_cd])," & @CRLF & _
" [daihyou_cd] [varchar](30) NOT NULL," & @CRLF & _
" [syuuyaku_cd] [timestamp]" & @CRLF & _
")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")