use strict;
my $str = 'CREATE TABLE [dbo].[m_category_link](
[category_link_id] [int] NOT NULL,
[category_id] [int] NULL,
[parent_id] [int] NULL,
[child_id] [int] NULL
) ON [PRIMARY]
GO
CREATE TABLE [dbo].[m_daihyou_syouhin_wk](
[daihyou_cd] [varchar](30) NOT NULL,
[syuuyaku_cd] [varchar](30) NULL,
[daihyou_mei] as ([daihyou_cd]+ [syuuyaku_cd]),
[daihyou_cd] [varchar](30) NOT NULL,
[syuuyaku_cd] [timestamp]
)';
my $regex = qr/(?i)(^ *)CREATE\s+TABLE\s+[^()]*\(([^()]*\([^()]*\))*[^()]*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}