#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-z]{2,5}+(-|[0-9]{2,8})"
Local $sString = "FC2PPV-2494277 【レビュコメ記載で特典映像】【独占販売】【完全顔出し】恵比寿の大手企業勤務、25歳。私の”醜態成”見て下さい。" & @CRLF & _
"FC2PPV-1181896 【中出し】色白ちっぱいのミニマム系S級美少女が電マをクリに当てながら悶絶!乱暴生ハメに狂う合法ロリJD【元アイ" & @CRLF & _
"SDDE657女装をして女湯に潜入しようとしたら、間違えて入った男湯がハッテン場だった件 星越かなめ" & @CRLF & _
"(無修正-流出) SDDE-326 (Uncensored Leaked)「常に性交」生本番ニュースショー 2 (Asakura Kotomi ,Hatsuki Nozomi ,Kohaku Uta)" & @CRLF & _
"(Mosaic Removed) SDDE-326 「常に性交」生本番ニュースショー 2" & @CRLF & _
"HD SDDE-659_6K" & @CRLF & _
"@bo99.tv_SDDE-659.mp4" & @CRLF & _
"SDDE-658【ALL自撮り動画】修学旅行中 東京で男を喰いまくったえっちな記録 新井リマ" & @CRLF & _
"SDDE-658~nyap2p.com.mp4" & @CRLF & _
"+++ [HD] SDDE-659 壁!机!椅子!から飛び出る生チ○ポが人気の放送局『(株)しゃぶりながらテレビ』…たまにハメながら!!" & @CRLF & _
"hhd800.com@SDDE-659.mp4" & @CRLF & _
"sdde-638 | Jav.mp4" & @CRLF & _
"sdde-638 | Jav.mp4" & @CRLF & _
"+++ [HD] SDDE-658 【ALL自撮り動画】修学旅行中 東京で男を喰いまくったえっちな記録 新井リマ" & @CRLF & _
"hhd800.com@SDDE-658.mp4" & @CRLF & _
"祝第2回開催 全裸婚活パーティー [SDDE-617] (SOD Create) [uncen] 2020 / 2021 DVDRip" & @CRLF & _
"SDDE-617-UNCENSORED-whole.mp4" & @CRLF & _
"[HD Uncensored] SDDE-578 トビジオっ!NEWSプラス 業務中/ずっと痙攣・潮吹きっぱなし・失禁しても平然と原稿を読み上げる女子アナ" & @CRLF & _
"SDDE-578.mp4" & @CRLF & _
"SDDE-578.1080p.mp4" & @CRLF & _
"SDDE-578.vi.srt" & @CRLF & _
"+++ [HD] STARS-491 朝ドラ系現役アイドルT〇kT〇ker 西元めいさ 小さなお口でたまきん、チ〇ポ、ケツ穴まで一生懸命ナメてナメて合計9発ぜ~んぶ顔射!おしゃぶりアイドル爆誕!#イク時は顔にかけて" & @CRLF & _
"hhd800.com@STARS-491.mp4" & @CRLF & _
"STARS-483 たまんない、その距離感。マジで恋する3秒前、一度はこんな子と恋をしたい。工藤ゆら AVデビュー" & @CRLF & _
"STARS-483~nyap2p.com.mp4" & @CRLF & _
"[MP4/1.77GB]【中文字幕】STARS445 因交替重複慢速而頭腦空白焦灼~天宮花南[VIP2209]+" & @CRLF & _
"avmans.com-STARS445C.mp4" & @CRLF & _
"STARS436向かい部屋の絶倫巨乳お姉さん(人妻)とひたすら騎乗位の練習 吉永このみ" & @CRLF & _
"avmans.com-STARS436C.mp4" & @CRLF & _
"[HD Uncensored] STARS-331 レ×プを誘う性欲ヤバすぎ人妻 マンネリSEXに飽きた妻は、他の男を誘惑して滅茶苦茶にヤラれたいドM変態願望を持っています。 紗倉まな (Sakura Mana)" & @CRLF & _
"stars331_Uncen.mp4" & @CRLF & _
"[HD Uncensored] STARS-145 いち夏、覚醒。汁まみれ 汗だく舐め合い体液どろどろ!濃密に絡み合う濃度200%のとてつもなくイヤラシイ性交 永野いち夏" & @CRLF & _
"stars-145_Uncen_6K.mkv" & @CRLF & _
"STARS-500 「大丈夫?おっぱい揉む?」人懐っこ神乳J〇が好き放題おっぱいを触[中文字幕]" & @CRLF & _
"STARS-500C.mp4" & @CRLF & _
"HD STARS-434 無水印" & @CRLF & _
"jav20s8.com@STARS-434.mp4" & @CRLF & _
"(無修正-流出) STARS-126 (Uncensored Leaked) 小泉ひなた むっちりプリケツをありえないほど露出しているデカ尻ノーパン女" & @CRLF & _
"STARS-126_Uncen.mp4" & @CRLF & _
"RCTD430 巨臀女子摔角手凛叶 痛恨的危险日直击!连奸中出死亡比赛! !" & @CRLF & _
"avmans.com-RCTD430.mp4" & @CRLF & _
"[RCTD-149] 狂捏乳頭NTR 高潮耐力賽" & @CRLF & _
"rctd149.mp4" & @CRLF & _
"[HD] RCTD-436 [中文字幕] 洗脳MCリベンジャーズ 朝日奈かれん" & @CRLF & _
"rctd-436ch.mp4" & @CRLF & _
"HD RCTD-434_6K" & @CRLF & _
"@bo99.tv_RCTD-434.mp4" & @CRLF & _
"[FHD/5.38GB] RCTD-430 巨乳女子プロレスラー凛叶 痛恨の危険日直撃!連姦中出しデスマッチ!!" & @CRLF & _
"RCTD-430-C.mp4" & @CRLF & _
"HUNTA-820 【本編開始30秒で即エッチ】超エロい巨乳お姉様だらけのシェアハウスに入居したら男はボク1人で6人のお姉様たちとエッチしまくり!レズ大乱交も…" & @CRLF & _
"avmans.com-HUNTA820C.mp4" & @CRLF & _
"hunta-917 | Jav.mp4" & @CRLF & _
"hunta-917 | Jav.mp4" & @CRLF & _
"(Uncensored Leaked) HUNTA-723 永井美雏无码流出" & @CRLF & _
"HUNTA-723.mp4" & @CRLF & _
"FC2PPV-1331743 他では絶対見られない1月出産3児のママ旦那持ちに内緒で生セックス [有]" & @CRLF & _
"FC2PPV-1331743.mp4" & @CRLF & _
"FC2PPV-1331235 【本物】正真正銘アイドル お*好き神乳&ロリカワで有名な2人組を待ち伏せ!あの子のモロ出しまんこ?おっぱい?マ" & @CRLF & _
"FC2PPV-1331235-1.mp4" & @CRLF & _
"FC2PPV-1255599 オジサンち●ぽ狂いの美人受付嬢さおりガチハメ②!! 受付嬢:さおりちゃん(22歳) [有]" & @CRLF & _
"fc2ppv-1255599.mp4" & @CRLF & _
"TNOZ-009 105cm極爆乳ツンデレ美少女レイヤー19歳【乳首だけで絶頂全身性感帯】【大量唾液Dキス長時間&イラマえずき汁噴射&失禁オシッコごく飲…" & @CRLF & _
"TNOZ-009.mp4" & @CRLF & _
"FSDSS-341 「看護師が射精管理もしてくれる噂は本当でした…」普通の入院[中文字幕]" & @CRLF & _
"FSDSS-341C.mp4" & @CRLF & _
"(無修正-流出) PLA-012 (Uncensored Leaked) 本能剥き出し生中出しセックス 水元ゆうな (Yuna Mizumoto)" & @CRLF & _
"PLA-012 Yuna Mizumoto -720p - UNCENSORED.mp4" & @CRLF & _
"(無修正-流出) ABP-576 (Uncensored Leaked) 絶対的鉄板シチュエーション 3 長谷川るい (Rui Hasegawa)" & @CRLF & _
"ABP-576 -1080p - UNC.mp4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")