#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[a-z]{1}[a-z0-9!#$%&'*+-\/=?^_`{|}~]{0,}@[a-z]{1}[a-z.0-9-]{0,}[a-z0-9]{1}\.[a-z0-9]{2,}$"
Local $sString = "opinionated email validation based on https://en.wikipedia.org/wiki/Email_address" & @CRLF & _
"" & @CRLF & _
"Valid email addresses" & @CRLF & _
"simple@example.com" & @CRLF & _
"" & @CRLF & _
"werw@mydomain.gov.us" & @CRLF & _
"very.common@example.com" & @CRLF & _
"very.co34mmon@example.com" & @CRLF & _
"disposable.style.email.with+symbol@example.com" & @CRLF & _
"other.email-with-hyphen@example.com" & @CRLF & _
"other.email-with-hyphen@ex12ample.com" & @CRLF & _
"other.email-with-hyphen@exa-mple.com" & @CRLF & _
"fully-qualified-domain@example.com" & @CRLF & _
"example-indeed@strange-example.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Invalid email addresses" & @CRLF & _
"user-@example.org (local part ending with non-alphanumeric character from the list of allowed printable characters)" & @CRLF & _
"x@example.com (one-letter local-part)" & @CRLF & _
"admin@mailserver1 (local domain name with no TLD, although ICANN highly discourages dotless email addresses[10])" & @CRLF & _
"user.name+tag+sorting@example.com (may go to user.name@example.com inbox depending on mail server)" & @CRLF & _
"user%example.com@example.org (% escaped mail route to user@example.com via example.org)" & @CRLF & _
"mailhost!username@example.org (bangified host route used for uucp mailers)" & @CRLF & _
"" & @CRLF & _
"example@s.example (see the List of Internet top-level domains)" & @CRLF & _
" @example.org (space between the quotes)" & @CRLF & _
"john..doe@example.org (quoted double dot)" & @CRLF & _
"Abc.example.com (no @ character)" & @CRLF & _
"A@b@c@example.com (only one @ is allowed outside quotation marks)" & @CRLF & _
"a"b(c)d,e:f;g<h>i[j\k]l@example.com (none of the special characters in this local-part are allowed outside quotation marks)" & @CRLF & _
"just"not"right@example.com (quoted strings must be dot separated or the only element making up the local-part)" & @CRLF & _
"this is"not\allowed@example.com (spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)" & @CRLF & _
"this\ still\"not\\allowed@example.com (even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com (local-part is longer than 64 characters)" & @CRLF & _
"i_like_underscore@but_its_not_allowed_in_this_part.example.com (Underscore is not allowed in domain part)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")