use strict;
my $str = 'opinionated email validation based on https://en.wikipedia.org/wiki/Email_address
Valid email addresses
simple@example.com
werw@mydomain.gov.us
very.common@example.com
very.co34mmon@example.com
disposable.style.email.with+symbol@example.com
other.email-with-hyphen@example.com
other.email-with-hyphen@ex12ample.com
other.email-with-hyphen@exa-mple.com
fully-qualified-domain@example.com
example-indeed@strange-example.com
Invalid email addresses
user-@example.org (local part ending with non-alphanumeric character from the list of allowed printable characters)
x@example.com (one-letter local-part)
admin@mailserver1 (local domain name with no TLD, although ICANN highly discourages dotless email addresses[10])
user.name+tag+sorting@example.com (may go to user.name@example.com inbox depending on mail server)
user%example.com@example.org (% escaped mail route to user@example.com via example.org)
mailhost!username@example.org (bangified host route used for uucp mailers)
example@s.example (see the List of Internet top-level domains)
@example.org (space between the quotes)
john..doe@example.org (quoted double dot)
Abc.example.com (no @ character)
A@b@c@example.com (only one @ is allowed outside quotation marks)
a"b(c)d,e:f;g<h>i[j\\k]l@example.com (none of the special characters in this local-part are allowed outside quotation marks)
just"not"right@example.com (quoted strings must be dot separated or the only element making up the local-part)
this is"not\\allowed@example.com (spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)
this\\ still\\"not\\\\allowed@example.com (even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)
1234567890123456789012345678901234567890123456789012345678901234+x@example.com (local-part is longer than 64 characters)
i_like_underscore@but_its_not_allowed_in_this_part.example.com (Underscore is not allowed in domain part)';
my $regex = qr/^[a-z]{1}[a-z0-9!#$%&'*+-\/=?^_`{|}~]{0,}@[a-z]{1}[a-z.0-9-]{0,}[a-z0-9]{1}\.[a-z0-9]{2,}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}