const regex = /(?<=#start)(.+)(?=#end)/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=#start)(.+)(?=#end)', 'gis')
const str = `#start
hello powershell regex
what is the equivalent of flags gis
#end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}