package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\b`)
var str = `192.168.1.1
Localhost 127.0.0.1
Mask 255.255.255.255
My local IP 192.168.0.110
256.0.0.0 not valid IP
0.192.128.257 not valid IP`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}