using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[(?P<text>.*?)\])\((?P<link>.*?)\)";
string input = @"This is a regex to detect markdown image links of the form 
{#fig:id}
{#fig:id tag=""B.1""}
{#fig:ch0_1_images-1 width=100%}





















";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}