// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\[(?P<text>.*?)\])\((?P<link>.*?)\)").unwrap();
let string = "This is a regex to detect markdown image links of the form 
{#fig:id}
{#fig:id tag=\"B.1\"}
{#fig:ch0_1_images-1 width=100%}





















";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}