package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:more|most)\s+\w*ly(*SKIP)(*F)|\w*ly\b`)
var str = `fastly onffly fly incomprehensibly totaly happily
lily sly more happily
most seriously`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}